The Land of Fernieville

OSX Leopard: freezing keyboard/mouse

Posted in Mac by fernieville on February 14, 2008

leopard_os_x.gifUPDATE: See this post for possible fix

Looks like I’m not the only one suffering from a lockout keyboard/mouse freeze on Leopard. I’ve searched the net and so far many different solutions have been offered (see below). Here are my symptoms:

– Trackpad will choke, stop responding but might return to normal.

– Trackpad dies, then keyboard and not even the power button will show the typical sleep/shutdown etc

– Only option left is to hard reboot.

Summary:

This thread definitely points to it being a Leopard problem. Many different hardware and upgrades to Leopard cause the problems. After 10.5.2, at least for me, the problem got worse.

Another person suggests pressing down the num-lock button until it becomes alive again. I haven’t tried this so I’ll update when it freezes again.

Supposedly Apple had already addressed the issue… funny for I remember seeing this update and thinking “good thing mine isn’t doing it.” Spoke too soon.

One user reports the same type of freezing I’m experiencing, but somehow related it to Parallels….I don’t run Parallels, I run VMWare, so it still looks like it’s Leopard doing it because it also happens if VMW isn’t running.

This other forum talks about a PRAM reset. Haven’t tried that…but again, the problem began only after Leopard.

The last option is of course to Archive/Install. Yuck.

I welcome any suggestions!!

Advertisements

12 Responses

Subscribe to comments with RSS.

  1. Amit Patel said, on February 18, 2008 at 11:04 pm

    I’m having the same issue … mouse pointer stops moving, sometimes the keyboard still works, but it freezes shortly after, power button doesn’t work, and a hard reboot is the only solution. This started shortly after installing 10.5.2 😦

  2. fernieville said, on February 19, 2008 at 1:18 am

    I’ve stopped playing with iCal (or turning it on period) and thus far no freezes. I can’t say that this is the reason though… definitely 10.5.2 IMO.

  3. Dan N said, on February 20, 2008 at 4:39 am

    I did an archive and reinstall because of the same issues… a day later.. FREEEEZE.. damnit~ As a desperation attempt, I yanked out my 3rd party RAM card to see if it might be the problem.. 2 days later, no freezing, aside from one time when I woke it up from sleep mode. Let me know if you figure anything out. Such a waste of time here, and I need this laptop running smoothly for software development.. ick

  4. fernieville said, on February 20, 2008 at 10:43 am

    I did a pram reset and haven’t touched iCal in a while. I also updated my logitech drivers (LCC) and its been days without a freeze. I’ll start working with iCal again and let you guys know.

  5. fernieville said, on March 4, 2008 at 5:20 pm

    iCal is not the reason. I notice it most often when unplugged from power.

  6. Sigurdur Armannsson said, on March 6, 2008 at 6:19 am

    Hi.

    I just zapped the PRAM on one mac that was having this keyboard problem. Worked great.

    Afterwards I think: Why did I not think of the PRAM? 😀

    Thanks a lot.

  7. fernieville said, on March 6, 2008 at 11:35 am

    glad it worked for ya! 🙂

  8. Larr said, on April 24, 2008 at 11:19 am

    I followed read THIS article (http://www.tuaw.com/2007/10/31/logitech-mouse-control-in-leopard/) and then un-installed all the Unsanity software, along with old version(s) of MicroSoft Mouse software. I then installed SteerMouse (http://plentycom.jp/en/steermouse/) and it seems to have solved my problems. You may want to check it out. If it continues to function/work properly… I’ll certainly PAY for the software.

  9. fernieville said, on May 28, 2008 at 3:02 pm

    See update above

  10. Cain said, on July 17, 2008 at 8:43 pm

    I plugged an external mouse in, and the external mouse works fine. this at least allows you to try and fix rather than reboot + PR

  11. fernieville said, on September 1, 2008 at 7:13 pm

    that doesn’t work for me. I’ve tried.

  12. Sebastian said, on March 11, 2009 at 8:39 am

    My prblem with the freezing keyboard started when i installed 3rd party memory. I don’t think it’s the os. Anyway, I zapped the PRAM 3 days ago and it’s been fine ever since.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: